Moodle and PHP Versions

all killer.  no filler.

Different version of Moodle require different versions of PHP.

•Moodle 1.9.x requires a minimum of PHP v 4.3.0 to run.
•Moodle 2.0 needs PHP v 5.2.8 or higher.
•Moodle 2.1 needs PHP v 5.3.x.
•Moodle 2.2 needs PHP v 5.3.2 or higher.
All our servers support both PHP 5.2 and PHP 5.3 (with the exception of Windows Shared & Chilisoft ASP servers). The default version is 5.2.x but PHP 5.3.x can be used instead.

Moodle 2.1

Moodle can be manually installed for Moodle 2.1, in which you will need to turn on PHP 5.3 for it to work properly. Please read the article on PHP 5.3 for instructions on how to do that.

Moodle 2.2

Moodle 2.2 will work in our environment, but you will need to turn on PHP 5.3 for it to work properly. It can be installed via QuickInstall, our in-house script auto-installer. You can find QuickInstall in your cPanel under Software/Services.

About Moodle

Moodle is a Course Management System (CMS), also known as a Learning Management System (LMS) or a Virtual Learning Environment (VLE). It is a Free web application that educators can use to create effective online learning sites